UW-Forum
http://forum.uw-operator.de/

MSExchange Autodiscover Benutzereinstellung PreferredSite
http://forum.uw-operator.de/viewtopic.php?f=3&t=416
Seite 1 von 1

Autor:  Ulrich Wiedholz [ Dienstag 22. März 2016, 15:18 ]
Betreff des Beitrags:  MSExchange Autodiscover Benutzereinstellung PreferredSite  Thema ist als GELÖST markiert

Problem:
Der Exchange Server (in diesem Beispiel mit Exchange 2010) hat viele Fehler im Ereignisprotokoll, die alle von der Aufgabenkategorie MSExchange Autodiscover kommen und alle ein Problem mit der Benutzereinstellung PreferredSite haben.

Erklärung:
Das Problem kommt eigentlich vom AD. Beziehungsweise den dort eingerichteten Seiten.
Der Exchange Server hat anscheinend ein Problem, wenn jemand von einer anderen Seite mit ihm Verbindung aufnimmt.
Seiten werden im AD normalerweise erstellt um eine räumliche Trennung (verschiedene Firmen-Standorte) abzubilden.

Lösung:
Die Lösung erfolgt am einfachsten per PowerShell.
Hier die Vorgehensweise die in meinem Fall erfolgreich war.

Zunächst kann man die Seite im Exchange prüfen:
Code:
Get-ClientAccessServer | ft Name,AutoDiscoverSiteScope
In meinem Fall stand hier nur eine Seite von 2 Seiten die im Active Directory-Standorte und -Dienste hinterlegt waren.

Wir schreiben uns das Ergebnis in eine Variable:
Code:
$Seiten = (Get-ClientAccessServer MAIL-SRV1).autodiscoversitescope
Die Variable kann nun einfach um den Namen der 2ten Seite (Standort2) ergänzt werden:
Code:
$Seiten += "Standort2"
Jetzt nur noch die Eintragungen der Variablen im Exchange weg schreiben:
Code:
Set-ClientAccessServer MAIL-SRV1 -AutoDiscoverSiteScope $Seiten
Somit haben wir in unserem Exchange Server 2010 (MAIL-SRV1) zusätzlich zum Standort1 noch den Standort2 hinzugefügt. Die Fehler im Ereignisprotokoll hörten sofort auf.

Seite 1 von 1 Alle Zeiten sind UTC+02:00
Powered by phpBB® Forum Software © phpBB Limited
https://www.phpbb.com/